Back
Maintenance

APP Migration

Completed 2 Apr at 12:00am CEST.

E-shop Fitness Blog
Completed

Maintenance completed

Posted 2 Apr at 12:00am CEST.
Started

Planned service window reserved for migration to the newer version of the e-shop

Posted 1 Apr at 11:00pm CEST.